Select Page

[Q&A] 맥북에 멀티 버전 자바 설치하기

QUESTION

안녕하세요.
맥북을 사용한지 며칠 안되서 많이 어렵네요

우선 질문은

1. 지금 맥에는 자바 1.8 이 설치 되어 있는 상태인데 원래 맥북에 기본적으로 설치되어 있는 건가요 ??
아니면 이전에 사용하던 사람이 설치를 해놓은 걸까요 ?

2. 자바 1.7을 설치하고 싶은데요 맥os용으로 다운을 받아야 하는 거로 알고 있는데 맞나요 ??

2번 질문이 맞다면

3. 맥 os용 자바 1.7을 설치하는 경로랑 방법을 알려주시면 감사하겠습니다.

ADVICE

1. Mac 모델 년도에 따라 다릅니다. OS X 10.7 Lion 버전(2011년)부터 Java 가 기본적으로 미포함되었으니까, 2012 이후 모델이면 이전 사용자가 확실히 자바 설치한 것 맞습니다.

2, 3. 오라클에서 JDK를 다운로드/설치해야만 인터넷/자바 가상머신 모두 1.7 버전으로 사용할 수 있습니다. (JRE 는 인터넷 플러그인만 포함)

Java SE Development Kit 7u80

 

위 링크 접속하여 Java SE Development Kit 7u80 / Mac OS X x64 를 다운로드 설치한 후, 터미널 ( 응용 프로그램 > 유틸리티  폴더)에서 .bash_profile  파일에 기본 자바 버전을 설정합니다. 자바 버전을 설정하지 않으면, 1.7을 설치한다 해도 계속해서 1.8 버전을 사용합니다.

다음은 터미널에서 실행할 명령입니다. () 된 것은 입력할 필요 없습니다.

 

터미널에서 자바 버전 확인

About The Author

ssumer

DoD Developer/Admin at University of Hawaii at Manoa, 저서: Mac QnA 실무 테크닉, Mac OS X 길라잡이(정보 문화사), Mac OS X 실무테크닉(성안당) / 기술 감역: 인텔 리얼센스 SDK 센서 프로그래밍(정보 문화사), 예제가 가득한 PHP 프로그래밍(정보 문화사), iPhone 가이드(성안당)

Leave a reply

Your email address will not be published. Required fields are marked *

Publications

쑤머의 집필서적

Recent Videos

Loading...

ADVERTISEMENT