Select Page

[HOW-TO] Mac OS X 10.6 에서 어도비 CS 5, 플래시 빌더 실행 문제 해결.

진작에 올리려고 했는데, 아이폰/아이패드 글을 쓰다 보니 시간이 한참 지났네요. 여하튼, Mac OS X 10.6 스노 레퍼드 상에서 어도비 CS5 를 설치하면, 몇몇 가지 프로그램들이 실행되지 않을 겁니다. (만약, 모두 잘 실행된다면, 아주 Lucky 한 케이스입니다.) 이와 같이 에러가 발생하는 이유는, Mac OS X 10.6 에는 기본적으로 자바(Java) 1.6 이 내장되어 있는데, 이 버전과 어도비의 플래시 빌더(Flash Builder 4), 플래시 카탈리스트(Catalyst) 등에서 사용하는 자바 라이브러리가 호환되지 않기 때문에 발생하는 것입니다.

 

Problem Reporterssumercap002

[자바 라이브러리 호환 문제로 플래시 빌더 4 가 실행되지 않습니다.(Mac OS X 10.6 Snow Leopard)]

 

여기서 한가지 중요한 부분을 다시 한번 확인하셨죠? “역시나 어도비는 게으르다~ (제 말이 아니라, 스티브잡스의 말입니다.)” CS 5 의 모든 구성 프로그램들이 코코어(Cocoa)기반의 완벽한 64비트 호환 프로그램들로 구성되어 있지 않고, 방금 언급한 플래시 빌더 및 플래시 카탈리스트 등은 여전히 카본(Carbon) 기반의 32bit 자바 라이브러리를 사용하고 있습니다. (이것은… 어도비 게으름도 문제지만, Eclipse 자바 라이브러리가 32비트 버전의 1.5 버전과만 호환되는 것도 문제입니다. – 얼른 좀 업데이트 하지…)

 

Flash Builderssumercap001

[플래시 빌더 4를 실행시킨 화면, 벌써 인터페이스가 “카본(Carbon)” 냄새가 물씬~ 풍기죠?]

 

이와 같이, 플래시 빌더/카탈리스트와 자바 라이브러리를 호환시켜 주기 위해서는, 어쩔 수 없이, Mac OS X 10.5 레퍼드용 버전 1.5 자바 라이브러리를 설치해 주어야만 하는데, 일반적인 설치 방법으로는 설치가 불가능합니다. 다음 단계를 참고하시면, 자바 라이브러리 1.5/1.6 모든 버전을 Mac OS X 10.6 스노 레퍼드에 설치하여, 자바 호환성 문제를 해결할 수 있습니다.

 

1. Pacifist 쉐어웨어 버전을 다운로드 받아 설치합니다. (정식 등록을 하지 않아도, 일정기간 모든 기능을 사용할 수 있음)

 

Finderssumercap004

 

2. 파인더에서 Macintosh HD > System(시스템) > Library (라이브러리) > Frameworks > JavaVM.framework > Versions 폴더로 이동한 뒤, 1.5 와 1.5.0 폴더를 삭제합니다. (매우 중요)

 

Finderssumercap005

[Versions 폴더의 1.5 와 1.5.0 폴더를 삭제합니다. (매우 중요)]

 

3. Mac OS X 10.5 레퍼드 용 자바(버전 1.5)를 다운로드 받고, 파인더(Finder)에서 마운트 시킨 뒤, Pacifist 로 자바 1.5 패키지를 오픈합니다.

 

Pacifistssumercap001

[Pacifist에서 오픈한 자바 버전 1.5(Mac OS X 10.5 레퍼드 용)에서 1.5 와 1.5.0 을 설치합니다.]

 

4. 오픈된 패키지에서 System > Library > Frameworks > JavaVM.framework > Versions 폴더의 1.5 와 1.5.0 을 선택하고 (Command 키 이용), 마우스 오른쪽 클릭 후, Install to Default Location 메뉴를 실행시킵니다. (관리자 패스워드를 입력하면, 자동으로 설치됩니다.)

5. 설치를 완료한 뒤, 파인더의 Utilities (유틸리티) 폴더에 위치한 Java Preferences 를 실행시켜서, 자바 라이브러리 우선 순위를 J2SE 5.0 32 Bit 를 가장 첫 순위로 이동시킵니다. (가장 첫 번째로 드래그시키면 됩니다.)

 

Finderssumercap006

 

Java Preferencesssumercap001

[Java Preferences 를 실행시키고, 자바 라이브러리 순위를 변경시켜 줍니다.]

 

6. 플래시 빌더 및 플래시 카탈리스트 등을 실행시켜서, 정상적으로 동작하는 확인합니다. (아마 자알~ 실행될 겁니다.)

 

Adobe Flash Catalystssumercap001

[플래시 카탈리스트가 정상적으로 실행된 화면]

About The Author

ssumer

DoD Developer/Admin at University of Hawaii at Manoa, 저서: Mac QnA 실무 테크닉, Mac OS X 길라잡이(정보 문화사), Mac OS X 실무테크닉(성안당) / 기술 감역: 인텔 리얼센스 SDK 센서 프로그래밍(정보 문화사), 예제가 가득한 PHP 프로그래밍(정보 문화사), iPhone 가이드(성안당)

Publications

쑤머의 집필서적

Recent Videos

Loading...

ADVERTISEMENT